Prestashop 1.6.1.6 admin fordítás hibája

A Magyar Prestashop Facebook Csoportban az alábbi anomáliára hívták fel a figyelmem:

“Sziasztok!

Találkozott már valaki azzal, hogy frissen telepített Prestashop 1.6.1.6, default-bootstrap téma, tulajdonképpen semmi nincs még beállítva, és a következő hibaüzenet fogad menüelemek fordításakor:

The class name ‘AdminParentModulesController’ cannot be found.”

A fent említett hiba az adminbeli menük fordításánál lép fel. Kicsit kutakodtam a témában és találtam egy prestashop.com topic-ot ahol szintén ugyanezzel a kérdéskörrel foglalkoznak, de megoldás nem volt benne.

Egy localhost-on frissen telepített 1.6.1.6-nál sikerült reprodukálnom a hibaüzenetet. Kikerestem a

/controllers/admin/AdminTabsController.php -t, és észrevettem, hogy egy frissen beletett kódrészlet okozza a hibát. Az alábbi képen ez látható:

prestashop_1616_forditasi_hiba

Ha a kijelölt részt kitöröljük, a hiba megoldódik. Miután Én és a Csoportbeli tagok is letesztelték, a fenti prestashop.com topic-ba is feltettem a javítást.

Minden bizonnyal a következő frissítés már nem fogja ezt tartalmazni.

Ha segített a cikk, meghívhatsz egy kávéra! 🙂


Puizl Attila Programozó

Az íróról: Puizl Attila

Puizl Attila vagyok, több éve készítek sikeres Webáruházakat Prestashop rendszerrel. Célom hogy a tudásom minőséggé, munkám pedig eredményessé váljon.

Weboldal: → Prestashop Készítés és Fejlesztés

Még megtalálsz:

Hamarosan letölthető állapotban lesz az új generáció: a Prestashop 1.7-es verziója! Ha követted a Prestashop hírfolyamát a szociális csatornákon akkor minden bizonnyal hallottál már az új 1.7-ről. Mik változtak benne? Mik az újdonságok? Egy kis kedvcsináló videó (angol): Fontos frissítések és újítások jönnek az 1.7-el Ha egyetlen szóval kellene összefoglalni…
Ha frissítjük Prestashop-unkat (1.4-ről 1.6.x-re, esetleg 1.5-ről 1.6.x-re) akkor találkozhatunk egy furcsa hibaüzenettel amikor a Preferences / SEO&URLs fülön magyarítani próbálunk egy oldalt: "Nem lehet beolvasni a "override" könyvtárat" vagy angolul: "Cannot scan "override" directory". A kellemetlen az ebben a hibában, hogy hiába kapcsoljuk be a developer-módot, semmivel sem leszünk okosabbak.…